Adobe Photoshop

If you are uploading individual images, simply upload your files to a photo gallery (300dpi sRGB JPG files) and use the Book Designer or Book Machine.

The instructions below are a How-To that meets our PDF Specs using Photoshop and Acrobat Pro to upload a complete PDF document use the PDF Wizard. Special thanks to Stephen Linhart for his excellent work getting this document together.

Some experience with Acrobat Pro and Photoshop is assumed. The specifics given are for Photoshop and Acrobat in Mac OS, but the commands are very similar in Windows.

Step 1: Page Size

Yearbook Find the page size you'll be using, including the full bleed. Use the size called PDF Upload Dimensions and prepare the pages in Photoshop at this size and 300dpi. Include the bleed even if none of your images bleed.

If you plan to make your book available for sale, prepare it for the largest book you will make available. The books ratios are Square Yearbooks, Portrait Yearbooks or Landscape Yearbooks. For example, if you are making a 12x12 Yearbook available for sale, we will also offer it at 10", 8.5", 5" and 3.5" square sizes. Similar relationships apply to the portrait and landscape books.

The Yearbook Catalog shows how much will be trimmed around the edges. Avoid 1/4 inch on each edge as an additional safety zone (in addition to the trim) it is important that this area not include important content, such as text.

Step 2: Left and Right Pages

Prepare templates for the left and right facing pages. Add at least 1/4" of additional safety in the gutter of the page. This area will be hard to see in the crease. Add more safety in the gutter if possible.

A left page is on the left hand side of the book when it is open. The gutter of a left page is on its right hand side. For a right facing page, the gutter is on the left.

In almost all books, page 1 will be a right facing page. But for calendars it will be a left facing page. You might call this a top page, because the calendar is ring bound at the top. So the first page is an upper page and its gutter is at the bottom. The first page of a calendar is on the inside surface of the cover.

Prepare left and right page templates in Photoshop with the page sizes from STEP 1 and the safety areas from STEP 2. Make the safety areas in their own layer. You can make this layer black and set the transparency to 20%. Be sure to turn this layer off before preparing your PDFs.

Step 3: Color Gamut

Our service works best if you send files in the sRBG color space. But it also helps to limit your colors to a narrower, more printable color space. You can do this by preparing your images in an InkJet printer color space and then converting them to sRGB before converting to PDF.

Keep the menu setting as Image > Mode > RGB throughout the whole process. We do not expect you to send CMYK files and does not work as well if you do. Converting your templates to the color space of your desktop printer using Edit > Convert to Profile is a good way to get a color space that can be printed well. Then convert to sRGB before saving as PDF.

Step 4: Prepare Your Pages

Of course this is most important step, but it's not really part of this tutorial. It helps if your pages follow a standardized format, because you can save effort by copying an existing (left or right) page to start each new page. But maybe your book is entirely wild and full of variation. This step should include any page numbers you will have.

Save each page after you make it. Make backups. If you have a lot of text, keep a copy in a text editor or word processor and do your proof reading there.

Next, convert the color profile to sRGB. Convert to
Profile is in the Edit menu. Convert to "sRGB IEC61966-2.1" with the Conversion Options set to Adobe (ACE), Relative Colorimetric, and Use Black Point Compensation. For best quality it is important to NOT Use Dither or Flatten. This is also the time to crop the image so no elements extend out of the image area. Select > All then Image > Crop.

Step 5: Save Individual Pdf Pages

When your pages are all ready, the next step is saving each page as a PDF. This process has a lot of very specific steps that you need to follow to get the best results.

First, be sure to hide the bleed and safe area layers and any other template layers. Also, be sure there is a background layer that fills the entire image area. Do this before saving the original Photoshop version of each page. This is also a good time to run Photoshop's spell checker. It may also be helpful to make sure your layers are in a consistent order at this stage. If you always have background then image then text (or any other consistent order) this could help later if you want to modify all your pages with a Script or Action.

Now you're ready to use the Save As menu to save as Photoshop PDF (choose Photoshop PDF in the Format pop-up in the Save dialog). You have a lot of control of the details of how a PDF is saved. The first step is the settings in the Save dialog itself. Layers should be on, so should Embed Profile. All the image layers will be collapsed into a single image layer. But text and vector objects will be preserved.

Next you'll get the PDF settings dialog (this is after the Save dialog and before the file is actually saved). Create a preset with Compatibility set to Acrobat 6 (PDF 1.5), Preserve Photoshop Editing Capabilities OFF, Compression set to Maximum quality JPEG, and Convert 16-bit to 8-bit. All security settings should be off. Down-sampling should be to 300dpi.

Step 6: Make A Droplet To Save Pages As Pdf

Because you need to do STEP 5 for each page, and each time you make a change, it helps to have a Photoshop Droplet to do it for you.

First make a New Action using the Actions palette from the Windows menu, record all the parts of STEP 5 (from conversion to sRGB to saving as PDF) as an Action that saves the file in place, but with the .pdf extension. Then use File > Automate > Create Droplet to make a Droplet that executes the Action you just made.

When you have all your Photoshop files ready, select them all and drag them onto the Droplet. This will open Photoshop and save each file as a PDF. At this point it helps to drag all the new PDF files into their own folder.

Step 7: Combine All The Pdf Pages Into A Single Document

Launch Acrobat Pro. Select File > Combine > Merge Files into a Single PDF. You'll want a Single PDF, NOT a PDF Portfolio. In the Combine Files Dialog, click the Add Files button and add all your PDF pages. You can do this in a single step by using shift-click to select all the files at once in the File Open Dialog. Use the Options button to turn all the Options on and set the File Size to the largest size.

When you click the Combine Files button it will create a file called Binder.pdf in the folder where your PDF files are. Binder.pdf is the first complete file of your book with all the inside pages.

Step 8: Prepare Your PDF

First you want use Acrobat to save your Binder.pdf as Postscript. You do this in Acrobat Pro using File > Save As. Set the file name to something descriptive. Set the Format to Postscript. Set the Postscript Settings to the Default for Device Independent. Now save your file next to Binder.pdf. It's important to use a new name, not 'Binder' so you don't write over Binder.pdf when you turn your .ps file back to a .pdf.

Now open Acrobat Distiller. You'll want a preset for using this website. You make this using Settings > Edit Adobe PDF Settings. In the General Tab, set Compatibility to Acrobat 6 (PDF 1.5). In the Images tab set Down-sampling to 300dpi so you don't reduce the quality of your images. Set the Compression to JPEG and the Quality to Maximum. In the Fonts tab Embed All Fonts, but you can Subset when the percentage of characters used is under 100% because this will include each font only once, so you won't get multiple subsets of the same font. In the Color tab you want Settings File to be None, and Color Management to Leave Colors Unchanged and Preserve Rendering Intent. This will get you the best color rendering. You don't need any of the settings in the Advanced or Standards tabs.

Now Save this preset with a new name and then drag your .ps file onto Acrobat Distiller. This will create a new PDF that will be in your folder next to your .ps file. To check that this file is ready, open it in Acrobat and use the Advanced > Preflight tool. In the Preflight dialog, select 'Digital printing (color)' and Analyze the file. If you see a green check mark and the words 'No Problems Found' your file is ready.

Step 9: Making Your Cover

For best results, your cover should be a separate file; either one wrap-around image, or one image for the front and one for the back. You prepare these files using the same process as you use for making the body of your book, but with two differences: 1) you get the dimensions in pixels from the website AFTER you upload your main document,
and 2) you can skip STEP 7. Be sure you do NOT skip STEP 8.

If you want to make your book available for sale or you want to make a hardcover, be sure to prepare a file that uses the Hardcover Trim Line shown on the Cover Options page after you upload your body PDF. Every hardcover PDF will work for softcover, but NOT every softcover PDF will work for hardcover.

If your book is portrait or landscape, or if it is square and 8.5 inches or smaller, a wrap around cover will work best, because there is no issue of the spine area being perfectly aligned.

If you are making a square book over 8.5 inches in size, prepare a front cover and a back cover. Your back cover won't be printed on larger books, so you can leave it blank, or make in unimportant. For large square books (if you plan to make them available for sale or
want the option of a smaller version) prepare your front cover for an 8.5" hardcover book. Scaling an 8.5" cover down for the label or cutout on the larger books will look good, but scaling a small label up to fill an 8.5" cover will result in poor quality. Evaluate the centering of the text on a square cover based on the Full Wrap Cover tab, not the Die-cut Cover tab.

For a professional look, avoid spine text in your images. The software accurately places spine text, and adjusts based on the binding type (hardcovers have wider spines for example). You can enter the spine text in Step 2 of the PDF wizard.

Finally, your covers should be saved out as 300 dpi sRGB JPEG files. Because covers are subject to manipulation (scaling or repositioning for hard/soft cover), all covers are rastered to a common RGB jpeg format prior to printing. Uploading a PDF produces no gains, and in fact turns rasterization control over to the software, as opposed to the fine tuned control you have in Photoshop.

Step 10: Get An FTP Account

Using FTP to upload images is a more reliable method of uploading large files. This will make the process of building books with large, graphic heavy PDF files smoother and quicker.

Again, special thanks to Stephen Linhart.